This issue has now been resolved. If you are continuing to experience any issues, please reach out to our support team by going to the Contact Us page or logging in to your portal.
Posted Jul 01, 2026 - 23:14 EDT
Identified
We’re currently experiencing degraded performance issues with client and provider login access from our home page. Our team is currently investigating in order to restore normal functionality. Clients can continue to log in by visiting growtherapy.com/client-dashboard. Providers can continue to log in by visiting provider.growtherapy.com. We apologize for any inconvenience and will post another update as soon as we learn more.
Posted Jul 01, 2026 - 19:00 EDT
Investigating
We’re experiencing a service outage with client login access from our homepage. Our team is currently investigating in order to restore the service. We apologize for any inconvenience and will post another update as soon as we learn more.
Posted Jul 01, 2026 - 18:49 EDT
This incident affected: Provider Portal and Client Portal.