Third Party Outage: Client and Provider Authentication

Incident Report for Grow Therapy

Resolved

This issue has now been resolved. If you are continuing to experience any issues, please reach out to our support team by going to the Contact Us page or logging in to your portal.
Posted Nov 16, 2025 - 15:39 EST

Monitoring

We are currently monitoring an outage with a third party dependency that is causing disruption in client and provider ability to login. We apologize for any inconvenience and are actively monitoring their status.
Posted Nov 16, 2025 - 15:02 EST
This incident affected: Provider Portal, Telehealth, and Client Portal.