Third Party Outage

Incident Report for Grow Therapy

Resolved

This issue has now been resolved. If you are continuing to experience any issues, please reach out to our support team by going to the Contact Us page or logging in to your portal.
Posted Oct 20, 2025 - 19:17 EDT

Update

We are continuing to monitor an outage with a third party dependency that is causing disruption. We apologize for any inconvenience and are actively monitoring their status.
Posted Oct 20, 2025 - 15:46 EDT

Monitoring

We are currently monitoring an outage with a third party dependency that is causing disruption. We apologize for any inconvenience and are actively monitoring their status.
Posted Oct 20, 2025 - 12:26 EDT
This incident affected: Provider Portal, Marketplace, Scheduling, Billing, Telehealth, Client Portal, and Third Party Dependencies.