Stripe degraded performance

Incident Report for Grow Therapy

Resolved

This issue has now been resolved. If you are continuing to experience any issues, please reach out to our support team by going to the Contact Us page or logging in to your portal.
Posted Jul 09, 2025 - 13:48 EDT

Monitoring

Our team is monitoring the resolution to address the degraded performance issues with Stripe ACH Payments. We apologize for any inconvenience and will post regular updates as Stripe works with banking partners to resolve this issue. Stripe has acknowledged the incident on their status page, which you can view here: https://status.stripe.com
Posted Jul 09, 2025 - 10:12 EDT
This incident affected: Third Party Dependencies.