This issue has now been resolved. If you are continuing to experience any issues, please reach out to our support team by going to the Contact Us page or logging in to your portal.
Posted Nov 18, 2025 - 11:50 EST
Monitoring
Our team is monitoring our resolution to address the degraded performance issues with Telehealth. We apologize for any inconvenience and will post regular updates as we resolve this issue.
Posted Nov 18, 2025 - 11:08 EST
Update
We’re currently experiencing degraded performance issues with Telehealth. Our team is continuing investigation in order to restore normal performance levels. We apologize for any inconvenience and will post another update as soon as we learn more.
Posted Nov 18, 2025 - 10:35 EST
Investigating
We’re experiencing a service outage with Telehealth. Our team is currently investigating in order to restore the service. We apologize for any inconvenience and will post another update as soon as we learn more.