Booking Issues - Availability
Incident Report for Grow Therapy
Resolved
This issue has now been resolved. If you are continuing to experience any issues, please reach out to our support team by going to the Contact Us page or logging in to your portal.
Posted Sep 22, 2024 - 17:31 EDT
Update
We are continuing to investigate this issue.
Posted Sep 22, 2024 - 17:31 EDT
Investigating
We are currently investigating this issue. There appears to be an issue with booking some providers on the marketplace.
Posted Sep 22, 2024 - 17:17 EDT
This incident affected: Marketplace and Scheduling.