Telehealth service outage

Incident Report for Grow Therapy

Resolved

This issue has now been resolved. We identified the root cause of this outage as a third party dependency.

If you are continuing to experience any issues, please reach out to our support team by going to the Contact Us page or logging in to your portal.
Posted Aug 21, 2025 - 16:07 EDT

Update

We’re experiencing a service outage with our telehealth platform. Our team is currently working on a resolution to restore the service. We apologize for any inconvenience and will post regular updates.
Posted Aug 21, 2025 - 14:58 EDT

Update

We are continuing to work on a fix for this issue.
Posted Aug 21, 2025 - 14:06 EDT

Identified

We’re experiencing a service outage with our telehealth platform. Our team is currently working on a resolution to restore the service. We apologize for any inconvenience and will post regular updates.
Posted Aug 21, 2025 - 14:04 EDT
This incident affected: Telehealth.